Skip to main content

CISCO devises configuration commands & info CCNA 200–301

 Repository with all the labs and necessary screenshots:

Configure the hostname :

Router>en
Router#conf t
Router(config)#hostname R1
R1(config)#

en is the shortcut for enable command. “ennable” is used to enter Privileged EXEC mode

conf t is the shortcut for configure terminalcommand. Used to enter the global configuration mode

delete or remove

Just put a no in front, it is same across all devices.

R1(config)#no interface g0/0.20

show ip interface

Checks the status of the interfaces

R1(config)#do show ip interface brief
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 unassigned YES unset administratively down down
GigabitEthernet0/1 unassigned YES unset administratively down down
GigabitEthernet0/2 unassigned YES unset administratively down down
Vlan1 unassigned YES unset administratively down down
R1(config)#

do at the front of the command is to run the command in the Privileged EXEC mode

Configure the appropriate IP addresses on R1, PC1, PC2, PC3, PC4

First, select the interface then assign the IP

R1(config)#interface g0/0
R1(config-if)#ip address 172.16.255.254 255.255.0.0
R1(config-if)#do show ip interface brief
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 172.16.255.254 YES manual administratively down down
GigabitEthernet0/1 unassigned YES unset administratively down down
GigabitEthernet0/2 unassigned YES unset administratively down down
Vlan1 unassigned YES unset administratively down down
R1(config-if)#

g0/0 → GigabitEthernet0/0

Manually configure the speed and duplex on interfaces

Gigabit Ethernet supports 1 Gb per second (Gbps) / 1000 megabit per sec so duplex is full

R1(config-if)#
R1(config-if)#speed 1000
R1(config-if)#duplex full

Write description & enable connection

R1(config-if)#description ## to SW 1 ##
R1(config-if)#no shutdown

Now the Status & Protocol will be “UP”

show interface

Displays statistics for the network interfaces.Checks the status of the interfaces

R1(config-if)#do show interface 
GigabitEthernet0/0 is up, line protocol is down (disabled)
Hardware is CN Gigabit Ethernet, address is 00e0.a31a.6801 (bia 00e0.a31a.6801)
Description: ## to SW 1 ##
Internet address is 172.16.255.254/16
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 100Mb/s, media type is RJ45
output flow-control is unsupported, input flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00,
Last input 00:00:08, output 00:00:05, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0 (size/max/drops); Total output drops: 0
Queueing strategy: fifo
Output queue :0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 watchdog, 1017 multicast, 0 pause input
0 input packets with dribble condition detected
0 packets output, 0 bytes, 0 underruns

Show running configuration and startup configuration

Running configuration:

→Display current, active configuration file

R1#show running-config
OR
R1#sh run

Startup configuration:

→Display saved configuration file which will be loaded when the device restarts

R1#show startup-config
OR
R1#sh start

At first it will say that “startup-config is not present”

Save running configuration to startup configuration

Different ways to save the configuration:

R1#write
OR
R1#write memory
OR
R1#copy running-config startup-config

Show interface status in switch

This command only works in switches not in routers

Switch#show int st
OR
Switch#show interfaces status
Port Name Status Vlan Duplex Speed Type
Fa0/1 connected 1 auto auto 10/100BaseTX
Fa0/2 connected 1 auto auto 10/100BaseTX
Fa0/3 notconnect 1 auto auto 10/100BaseTX
Fa0/4 notconnect 1 auto auto 10/100BaseTX
Fa0/5 notconnect 1 auto auto 10/100BaseTX
Fa0/6 notconnect 1 auto auto 10/100BaseTX
Fa0/7 notconnect 1 auto auto 10/100BaseTX
Fa0/8 notconnect 1 auto auto 10/100BaseTX
Fa0/9 notconnect 1 auto auto 10/100BaseTX
Fa0/10 notconnect 1 auto auto 10/100BaseTX
--More--

Name is the section for description

Disable interfaces which are not connected to other devices

We are using the range to call all at once


Switch(config-if-range)#int range g0/2 , f0/3 - 24
Switch(config-if-range)#description ## not in use ##
Switch(config-if-range)#shutdown

Now it will look like:

Switch(config-if-range)#do sh int st
Port Name Status Vlan Duplex Speed Type
Fa0/1 connected 1 auto auto 10/100BaseTX
Fa0/2 connected 1 auto auto 10/100BaseTX
Fa0/3 ## not in use ## disabled 1 auto auto 10/100BaseTX
Fa0/4 ## not in use ## disabled 1 auto auto 10/100BaseTX
Fa0/5 ## not in use ## disabled 1 auto auto 10/100BaseTX
Fa0/6 ## not in use ## disabled 1 auto auto 10/100BaseTX
Fa0/7 ## not in use ## disabled 1 auto auto 10/100BaseTX
--More--

Status is “disabled”

Default gateway

The default gateway is the path used to pass information when the device doesn’t know where the destination is.

The default gateway is used to reach locations outside of the local network. When a device wants to send a packet to a destination outside of its own network, it needs to forward the packet to a router that can forward it towards the destination. The router that connects the local network to other networks is typically configured as the default gateway.

Static Routing

We tell the router when we get a destination IP in the format `192.168.4.0/24` forward it to the next-hop/ next-router at `192.168.13.3`.Check day 11 in the repo.

ip route network-ip  netmask  next-hop

Example: R1(config)#ip route 192.168.4.0 255.255.255.0 192.168.13.3

OR

Subnetting

A subnetwork or subnet is a logical subdivision of an IP network.Subnetting is a method of dividing a single physical network into logical sub-networks (subnets)

VLSM & FLSM

FLSM (Fixed Length Subnet Mask) is a subnetting technique that allocates the same number of IP addresses to all subnets within a network, regardless of their size. In FLSM, the subnet mask used for all subnets is the same, and the subnets are created by dividing the network into equal-sized segments. This means that if a network needs to accommodate different numbers of hosts in different subnets, FLSM is not an ideal solution.

VLSM (Variable Length Subnet Mask) is a more flexible subnetting technique that allows different subnets to have different subnet masks, depending on their size and the number of hosts they need to accommodate. VLSM allows for more efficient use of IP addresses because it can allocate smaller subnets to those subnets that require fewer hosts, and larger subnets to those subnets that need more hosts.

VLSM (Variable Length Subnet Mask) is a more flexible subnetting technique that allows different subnets to have different subnet masks, depending on their size and the number of hosts they need to accommodate. VLSM allows for more efficient use of IP addresses because it can allocate smaller subnets to those subnets that require fewer hosts, and larger subnets to those subnets that need more hosts.

Configure SW 1(switch)interfaces in the proper VLANs. Remember the interfaces that connect to R1(router)! Name the VLANs

SW1(config)#int range g1/1,f5/1,f6/1
SW1(config-if-range)#switchport mode access
SW1(config-if-range)#switchport access vlan 20
SW1(config-if-range)#vlan 10
SW1(config-vlan)#name ENGINEERING
SW1(config-vlan)#vlan 20
SW1(config-vlan)#name HR
SW1(config-vlan)#do sh vlan brief

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa9/1
10 ENGINEERING active Gig0/1, Fa3/1, Fa4/1
20 HR active Gig1/1, Fa5/1, Fa6/1
30 SALES active Gig2/1, Fa7/1, Fa8/1
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active

“Switchport mode access” command forces the port to be an access port, any device plugged into this port will only be able to communicate with other devices that are in the same VLAN

Configure the connection between switches as a trunk, allowing only the necessary VLANs

SW1(config-if-range)#int g0/1
SW1(config-if)#switchport mode trunk
SW1(config-if)#switchport trunk allowed vlan 10,30
SW1(config-if)#switchport trunk native vlan 1001
SW2(config-if)#do sh int trunk
Port Mode Encapsulation Status Native vlan
Gig0/1 on 802.1q trunking 1001

Port Vlans allowed on trunk
Gig0/1 10,30

Port Vlans allowed and active in management domain
Gig0/1 10

Port Vlans in spanning tree forwarding state and not pruned
Gig0/1 10

SW2(config-if)#vlan 30
SW2(config-vlan)#do sh int trunk
Port Mode Encapsulation Status Native vlan
Gig0/1 on 802.1q trunking 1001

Port Vlans allowed on trunk
Gig0/1 10,30

Port Vlans allowed and active in management domain
Gig0/1 10,30

Port Vlans in spanning tree forwarding state and not pruned
Gig0/1 10,30

SW2(config-vlan)#

The Native VLAN is simply the one VLAN which traverses a Trunk port without a VLAN tag. An unused vlan is used here as native vlan for demonstration.

VLan 30 is not shown in Vlans allowed and active in management domain in switch 2 ,vlan 30 is only in switch 1 this is a problem as sw2 will not receive vlan30 traffic on this trunk ,so we create vlan30.

SVI

Switch Virtual Interface is a virtual interface configured on a Cisco switch that allows the switch to route traffic between different VLANs.SVI (Switch Virtual Interface) is a feature that is supported on Layer 3 switches.

Layer 3 switches have the ability to route traffic between different VLANs, which is a requirement for SVI functionality.Layer 2 switches operate only at the data link layer and do not have the ability to route traffic between different VLANs. Therefore, Layer 2 switches do not support SVI.Most modern Cisco switches support Layer 3 functionality, including popular models such as the Cisco Catalyst 2960, 3560, and 3750 series switches.

Command to enable layer 3 routing in a switch:

SW2(config)#ip routing

Command to configure interface as a “ routed port ” (layer 3 port),not layer2/switchport:

SW2(config)#int g1/0/2
SW2(config-if)#no switchport

Set default route pointing to Router(R1):

SW2(config-if)#exit
SW2(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.194
SW2(config)#do sh ip route

Gateway of last resort is 10.0.0.194 to network 0.0.0.0

10.0.0.0/30 is subnetted, 1 subnets
C 10.0.0.192 is directly connected, GigabitEthernet1/0/2
S* 0.0.0.0/0 [1/0] via 10.0.0.194

Check if the port is routed:


SW2(config-if)#do show interface status
Port Name Status Vlan Duplex Speed Type
Gig1/0/1 connected trunk auto auto 10/100BaseTX
Gig1/0/2 connected routed auto auto 10/100BaseTX
Gig1/0/3 connected 20 auto auto 10/100BaseTX
Gig1/0/4 connected 10 auto auto 10/100BaseTX
Gig1/0/5 connected 10 auto auto 10/100BaseTX
Gig1/0/6 notconnect 1 auto auto 10/100BaseTX
Gig1/0/7 notconnect 1 auto auto 10/100BaseTX

Assign ip address to Vlan’s:

SW2(config)#interface vlan 10
SW2(config-if)#ip address 10.0.0.62 255.255.255.192
SW2(config-if)#int vlan 20
SW2(config-if)#ip address 10.0.0.126 255.255.255.192
SW2(config-if)#int vlan 30
SW2(config-if)#
%LINK-5-CHANGED: Interface Vlan30, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to up

SW2(config-if)#ip address 10.0.0.190 255.255.255.192
SW2(config-if)#do sh ip int brief

GigabitEthernet1/1/4 unassigned YES unset down down
Vlan1 unassigned YES unset administratively down down
Vlan10 10.0.0.62 YES manual up up
Vlan20 10.0.0.126 YES manual up up
Vlan30 10.0.0.190 YES manual up up
SW2(config-if)#

Let’s check if the ping works, ping vlan30 from vlan 10:

Spanning tree protocol (STP)

Used to prevent layer 2 loops and broadcast storms and is also used for network redundancy.

Check the current STP topology:

SW1#show spanning-tree 

VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 32769
Address 0001.4301.4B81
Cost 19
Port 3(FastEthernet0/3)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 0060.2F90.D14A
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20

Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/1 Altn BLK 19 128.1 P2p
Fa0/2 Desg FWD 19 128.2 P2p
Fa0/3 Root FWD 19 128.3 P2p

VLAN0002
Spanning tree enabled protocol ieee
Root ID Priority 32770
Address 0001.4301.4B81
Cost 19
Port 3(FastEthernet0/3)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32770 (priority 32768 sys-id-ext 2)
Address 0060.2F90.D14A
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20

Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/1 Altn BLK 19 128.1 P2p
Fa0/2 Desg FWD 19 128.2 P2p
Fa0/3 Root FWD 19 128.3 P2p

F0/3 is the root port so SW2 is the root bridge.

Configure load balancing:

SW2(config)#spanning-tree vlan 1 root secondary 
SW2(config)#spanning-tree vlan 2 root primary

Increase the cost:

SW2

Comments

Popular posts from this blog

Bug Boundy Methodology, Tools & Resources

Start by defining a clear objective, such as exploiting a remote code execution (RCE) vulnerability or bypassing authentication on your target. Then, consider how you can achieve this goal using various attack vectors like XSS, SSRF, or others - these are simply tools to help you reach your objective. Use the target as how a normal user would, while browsing keep these questions in mind: 1)How does the app pass data? 2)How/where does the app talk about users? 3)Does the app have multi-tenancy or user levels? 4)Does the app have a unique threat model? 5)Has there been past security research & vulnerabilities? 6)How does the app handle XSS, CSRF, and code injection?

Install & set up mitmweb or mitmproxy in Linux

Step 1: Go to the mitmproxy page and download the binaries. Step 2: Install the downloaded tar file with the command " tar -xzf <filename>.tar.gz " Step 3: In the FoxyProxy add the proxy 127.0.0.1:8080  and turn it on. Step 4 : In the terminal run command " ./mitmweb " Step 5: Go to the page  http://mitm.it/   and download the mitmproxy's Certificate. Step 6: If you downloaded the certificate for Firefox, then go to " settings -> Privacy & Security -> Click View Certificates -> Click  Import ", then import the certificate.  Step 7: Now you are ready to capture the web traffic. Step 8 : In terminal run " ./mitmweb"

pip error in Kali Linux: error: externally-managed-environment : SOLVED

 error: externally-managed-environment × This environment is externally managed ╰─> To install Python packages system-wide, try apt install     python3-xyz, where xyz is the package you are trying to     install.     If you wish to install a non-Kali-packaged Python package,     create a virtual environment using python3 -m venv path/to/venv.     Then use path/to/venv/bin/python and path/to/venv/bin/pip. Make     sure you have pypy3-venv installed.     If you wish to install a non-Kali-packaged Python application,     it may be easiest to use pipx install xyz, which will manage a     virtual environment for you. Make sure you have pipx installed.     For more information, refer to the following:     * https://www.kali.org/docs/general-use/python3-external-packages/     * /usr/share/doc/python3.12/README.venv note: If you believe this is a mistake, please contac...